We have updated our Terms of Service, Code of Conduct, and Addendum.

Provider only is able to send webhooks to 80/443/8443

Tony Reinke - Cribl
Tony Reinke - Cribl Posts: 134 admin
edited September 20 in Cloud

gonna sound funny but a Popular vendor in our telecom world does support sending webhook notifications for alarms/alerts (but the problem it only sends to 80 / 443 / 8443 (no custom port) i dont think cribl cloud supports these ports (but is there a online proxy like ngrok or something that i can send/relay to cribl cloud (i dont wanna cloud ---> punch hole through FW to allow 443/8443 and then back to criblCloud at least in this simple POC approach


Original Thread on https://cribl-community.slack.com/archives/C022FME74PM/p1695069411755299

Best Answer

  • Jon Rust
    Jon Rust Posts: 402 mod
    Answer ✓

    There is an opening for Kinesis Firehose listening on 443. You can repurpose as you please.Under Network Settings on the cloud landing page, where all the ports are shown, KFH is separated out:

    so if you set-up a source on 10443, the outside interface will be 443



Answers

  • Jon Rust
    Jon Rust Posts: 402 mod
    Answer ✓

    There is an opening for Kinesis Firehose listening on 443. You can repurpose as you please.Under Network Settings on the cloud landing page, where all the ports are shown, KFH is separated out:

    so if you set-up a source on 10443, the outside interface will be 443



  • ohhh so i could send that or take that off and move it to http or is that a support request option

  • Ahmed Kira
    Ahmed Kira Posts: 33 mod

    You can do this yourself. No support request required. Disable the Firehose source in your cribl.cloud env. Create a new http or http-raw source. When creating the new source, copy and paste the certificate keys from the firehose source to the new source. That is under the source TLS settings

  • hmmmmmm okay

  • Ahmed Kira
    Ahmed Kira Posts: 33 mod

    And dont forget commit and deploy

  • cool
    ya the commit/deploy is a new thing im like wait ya i have to do that
    lol

  • Jon Rust
    Jon Rust Posts: 402 mod

    sorry, fell asleep at the wheel! thanks @ahmedkira